We expect that Identity Recovery for Microsoft Entra ID will be unavailable while we are improving the product as follows:
Customers may experience approximately 60 minutes of service interruption, during which they may not be able to access the portal to view backup status and statistics, perform restore operations, or view differences.
Unfortunately, we are unable to provide an exact time within the maintenance window when organizations may be affected.
There is also a possibility that some running backups will be interrupted. Any affected backups will automatically resume at the next scheduled time.
Posted Jul 10, 2026 - 13:33 UTC
Scheduled
We expect that Security Management Platform will be available for use while we are improving the product.
Posted Jun 24, 2026 - 14:02 UTC
This scheduled maintenance affects: Identity Recovery for Microsoft Entra ID (US Region, EU Region, UK Region).