On Demand Improvement with Downtime
Scheduled for Oct 26, 16:00 - 18:30 UTC
Update
We expect that On Demand Recovery will be unavailable in the US Region for up to ninety (90) minutes while we are improving the product. Customers will not be able to perform backups or recoveries until On Demand Recovery is available.

We expect that On Demand Audit will be unavailable for up to two (2) hours while we are improving the product. Customers will not be able to perform searches, receive alerts, or configure On Demand Audit. Customers will not have access to updated data in their Dashboards or Visualizations until On Demand Audit is available.
Posted Oct 18, 2021 - 18:10 UTC
Scheduled
We expect that On Demand Audit will be unavailable for up to two (2) hours while we are improving the product. Customers will not be able to perform searches, receive alerts, or configure On Demand Audit. Customers will not have access to updated data in their Dashboards or Visualizations until On Demand Audit is available.
Posted Sep 28, 2021 - 16:00 UTC
This scheduled maintenance affects: Recovery (US Region) and Audit (US Region, Australia Region, Canada Region, EU Region, UK Region).