On Demand Recovery Backups Impacted
Incident Report for Quest On Demand
Resolved
This incident has been resolved.
Posted Mar 27, 2023 - 13:26 UTC
Investigating
We are aware of a potential issue that is impacting backups for On Demand Recovery customers in the UK and EU region(s). An investigation
is currently underway, and we will report back soon.
Posted Mar 24, 2023 - 19:51 UTC
This incident affected: Recovery (EU Region, UK Region).