Production incident - On Demand Backup and Recovery for Azure AD affected
Incident Report for Quest OnDemand
Resolved
This incident has been resolved.
Posted 4 days ago. May 15, 2019 - 21:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 4 days ago. May 15, 2019 - 13:27 UTC
Investigating
We have detected a potential issue with the On Demand Backup and Recovery for Azure AD Service and it is operating in an impaired state. Operations can take longer than usual.

An investigation is currently underway and we will report back soon.
Posted 5 days ago. May 15, 2019 - 10:10 UTC
This incident affected: Recovery (US region).