Production incident - On Demand Backup and Recovery for Azure AD affected
Incident Report for Quest On Demand
Resolved
This incident has been resolved
Posted 23 days ago. Aug 26, 2019 - 11:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 24 days ago. Aug 25, 2019 - 11:56 UTC
Identified
We have detected a potential issue with the On Demand Backup and Recovery for Azure AD Service and it is operating in an impaired state.

An investigation is currently underway and we will report back soon.
Posted 24 days ago. Aug 25, 2019 - 11:09 UTC
This incident affected: Recovery (US region, Canada region, EU region).