On Demand Improvement with Downtime
Scheduled for Jan 26, 16:00 - 18:30 UTC
Update
On Demand Recovery backup jobs are expected to fail while we are improving the product.
Scheduled 10AM EST backups will be skipped proactively for this reason.
Following the maintenance, Recovery backup jobs will run as normal.
Posted Jan 19, 2021 - 21:21 UTC
Update
We expect that On Demand Audit, Migration and Recovery will be unavailable while we are improving the product.

On Demand Audit customers will not be able to perform searches, receive alerts, or update configurations. Customers will not be able to access updated data in their Dashboards or Visualizations until On Demand Audit is available again.
Posted Jan 19, 2021 - 08:20 UTC
Scheduled
We expect that On Demand Audit will be unavailable for up to ninety (90) minutes while we are improving the product. Customers will not be able to perform searches, receive alerts, or update configurations. Customers will not be able to access updated data in their Dashboards or Visualizations until On Demand Audit is available again.
Posted Dec 29, 2020 - 16:01 UTC
This scheduled maintenance affects: Audit (US Region, Australia Region, Canada region, EU Region, UK region), Migration for OneDrive (US Region, Australia Region, Canada Region, EU Region, UK Region), Migration for SharePoint (US Region, Australia Region, Canada Region, EU Region, UK Region), Migration for Microsoft Teams and Office 365 Groups (US Region, Australia Region, Canada Region, EU Region, UK Region), Migration for Email and Public Folders (US Region, Australia Region, Canada Region, EU Region, UK region), Recovery (US Region, Canada Region, EU Region, UK region), and Recovery for Microsoft Teams (US Region, Canada Region, EU Region, UK Region).